Transmission Site Outage (Montrose) due to a power outage Thursday 10th June 2021 08:00:00


There are major power outages across areas of Melbourne after a night of Wild weather.

Currently Montrose transmission site has no power.

Ausnet (the local power distributor) are working on restoring power to the area.

Update 11/6 1830 - Power has been restored by Ausnet.

If your service does not restore automatically, please restart your router before contacting Summit support.

Update 11/6 0700

SPAusnet are still yet to restore power. There is currently an ETA of 13/6 at 1300hrs.

We apologise for the outage due to the widespread power event.