Inbound calls from mobile phones fail Tuesday 10th March 2020 10:16:00


We are aware of an issue affecting some customers where calls from mobile phones are not connecting. Engineers are currently investigating, further updates will be posted when available.

Update 10:30am : Engineers have determined the issue is with an upstream carrier. We have been in contact with the carrier and they are investigating and working to resolve the issue.

Update 12:00 - We have seen no further issues and the upstream carrier has advised that all services have been restored.

We apologise for the interruption to your service.

Update 11.10 - Our upstream carrier has reported that they have resolved their fault as at 11.01am.

We are currently watching the situation before marking this as resolved.

Summit engineers have investigated and found the fault to be in an upstream carriers network.

A fault has been raised to the affected carrier and they are currently investigating.

There is currently no ETA.