Service Interruption Friday 24th May 2019 14:47:15


Engineers are currently investigating reports from alerting of issues in our Melbourne Datacentre.

More information will be made available once further investigations have occurred.

Update 1700 - Engineers are reviewing logs. All services are restored and stable.

Update 1524 - Engineers are investigate a single piece of equipment which appears to have rebooted unexpectedly.

All services have been restored and our Network Operations Team are currently monitoring.